描述 73 88 1 02 7 4 44 5 2 6 5(Figure 1)Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 输入Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.输出Your program is to write to standard output. The highest sum is written as an integer.样例输入5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5样例输出30import java.util.Scanner;
public class Main {
public static void main(String[] args) {
int N =0;
int num= 0;
Scanner input = new Scanner(System.in);
N = input.nextInt();
int[][] list = new int[N][N];
for(int i =1;i<=N;i++){
for(int j=1;j<=i;j++){
list[i][j] = input.nextInt();
num= num+list[i][j];
}
}
System.out.println(num);
}
}
添加回答
举报
0/150
提交
取消