为了账号安全,请及时绑定邮箱和手机立即绑定

本题要求实现函数,可以返回一个给定月份的英文名称。

本题要求实现函数,可以返回一个给定月份的英文名称。

C
幸福30 2016-12-30 16:16:50
本题要求实现函数,可以返回一个给定月份的英文名称。函数接口定义:char *getmonth( int n );函数getmonth应返回存储了n对应的月份英文名称的字符串头指针。如果传入的参数n不是一个代表月份的数字,则返回空指针NULL。裁判测试程序样例:#include <stdio.h> char *getmonth( int n ); int main() {     int n;     char *s;     scanf("%d", &n);     s = getmonth(n);     if ( s==NULL ) printf("wrong input!\n");     else printf("%s\n", s);     return 0; } /* 你的代码将被嵌在这里 */输入样例1:5输出样例1:May输入样例2:15
查看完整描述

2 回答

已采纳
?
望远

TA贡献1017条经验 获得超1032个赞

#include<stdio.h>
char *getmonth( int n )
{
	switch(n)
	{
	case 1:return "January";
	case 2:return "February";
	case 3:return "March";
	case 4:return "April";
	case 5:return "May";
	case 6:return "June";
	case 7:return "July";
	case 8:return "August";
	case 9:return "September";
	case 10:return "October";
	case 11:return "November";
	case 12:return "December";
	default:return NULL;
	}
}
int main()
{
	int n;
    char *s;
    scanf("%d", &n);
    s = getmonth(n);
    if ( s==NULL ) printf("wrong input!\n");
    else printf("%s\n", s);
    return 0;
}


查看完整回答
1 反对 回复 2016-12-30
?
幸福30

TA贡献3条经验 获得超0个赞

谢谢!


查看完整回答
反对 回复 2017-02-24
  • 2 回答
  • 0 关注
  • 9658 浏览

添加回答

举报

0/150
提交
取消
意见反馈 帮助中心 APP下载
官方微信