为了账号安全,请及时绑定邮箱和手机立即绑定

编写函数找素然后根据给定的两个数(不定大小顺序) 统计两个数之间(包括自身)的素数个数

编写函数找素然后根据给定的两个数(不定大小顺序) 统计两个数之间(包括自身)的素数个数

C C++
haligongoj 2016-10-27 18:13:55
编写找素数函数,然后根据给定的两个数(不定大小顺序) 统计两个数之间(包括自身)的素数个数 input 输入n行 每行两个整数 没有大小顺序 output 输出n行 每行一个整数 有回车 sample input 2 10 20 30 sample output 4 2
查看完整描述

1 回答

?
望远

TA贡献1017条经验 获得超1032个赞

#include<stdio.h>
void main()
{
	int n,m,temp;
	int i,j,flag,num=3;
	while(num--)
	{
		printf("请输入两个正整数:");
		scanf("%d%d",&n,&m);
		if(n>m)
		{
			temp=n;
			n=m;
			m=temp;
		}
		printf("[%d,%d]之间的素数有:\n",n,m);
		for(i=n;i<m+1;i++)
		{
			flag=1;
			for(j=2;j<i;j++)
			{
				if(i%j==0)
				{
					flag=0;
					break;
				}
			}
			if(flag)
			{
				printf("  %d  ",i);
			}
		}
		printf("\n");
	}
}

运行结果:

//img1.sycdn.imooc.com//5811d7db0001893404830196.jpg

查看完整回答
反对 回复 2016-10-27
  • 1 回答
  • 0 关注
  • 1306 浏览

添加回答

举报

0/150
提交
取消
意见反馈 帮助中心 APP下载
官方微信