-
命名空间中有若干个类
查看全部 -
for (int i = 1; i <= 7; i++)
{
for (int j = 1; j <= 7; j++)
{
Console.Write(i ==j || i + j == 8 ? 'O' : '.');
}
Console.WriteLine();
}
查看全部 -
10.各位相加
给定一个非负整数 num,反复将各个位上的数字相加,直到结果为一位数。返回这个结果。
输入样例1:
在这里给出一组输入。例如:
38
输出样例1:
在这里给出相应的输出。例如:
2
解释样例2:
数字38各位相加的过程为:
38 --> 3 + 8 --> 11
11 --> 1 + 1 --> 2
由于 2 是一位数,所以返回 2。输入样例2:
在这里给出一组输入。例如:
0
输出样例2:
在这里给出相应的输出。例如:
0
using System;
class Program
{
static void Main()
{
int n = Convert.ToInt16(Console.ReadLine());
while(n > 9)
{
int sum = 0;
while(n != 0)
{
sum += n % 10;
n /= 10;
}
n = sum;
}
Console.WriteLine(n);
}
}
查看全部 -
8.寻找数组中的最小值
寻找数组中最小值
注意:数组中元素并不一定是整数
输入格式:
第一行输入为数组元素的个数,假设为n
第二行输入为数组中的第一个元素
...
第N输入为数组的最后一个元素输出格式:
输出数组中的最小值
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
namespace ConsoleApplication1
{
class Program
{
static void Main(string[] args)
{
int num = Convert.ToInt32(Console.ReadLine());
double[] arr = new double[num];
double min = arr[0];
for (int i = 0; i < arr.Length; i++)
{
arr[i] = double.Parse(Console.ReadLine());
if (arr[i] < min)
min = arr[i];
}
Console.WriteLine(min);
}
}
}
查看全部 -
7.寻找数组中的最大值
寻找数组中最大值
注意:数组中元素并不一定是整数
输入格式:
第一行输入为数组元素的个数,假设为n
第二行输入为数组中的第一个元素
...
第N输入为数组的最后一个元素输出格式:
输出数组中的最大值
using System;
class Program
{
static void Main()
{
int n = Convert.ToInt16(Console.ReadLine());
double max = -0x3f3f3f3f;
for(int i = 0; i < n; ++i)
{
double tmp = Convert.ToDouble(Console.ReadLine());
if(tmp > max)
{
max = tmp;
}
}
Console.WriteLine(max);
}
}
查看全部 -
6.计算整数n到整数m之间数的总和
计算整数n到整数m之间数的总和
输入格式:
第一行输入整数n
第二行输入整数m输出格式:
输出和
using System;
class Program
{
static void Main()
{
int n = Convert.ToInt16(Console.ReadLine());
int m = Convert.ToInt16(Console.ReadLine());
int sum = 0;
for(int i = n; i <= m; ++i)
{
sum += i;
}
Console.WriteLine(sum);
}
}
查看全部 -
5.求解分段函数
编写程序,求解如下分段函数:
当x≤0时f(x)=x2+2
当x>0时f(x)=x+3
注意:
x为整数
输入格式:
输入为x
输出格式:
输出为f(x)
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
namespace ConsoleApp1
{
internal class Program
{
static void Main(string[] args)
{
double x;
x = Convert.ToDouble(Console.ReadLine());
if (x <= 0)
{
Console.WriteLine(x*x+2);
}
else
{
Console.WriteLine(x+3);
}
}
}
}
查看全部 -
4.查询成绩
输入一个成绩:
如果成绩大于等于60,则输出恭喜您,您通过了这次考试!
否则输出非常抱歉,您没有通过此次考试!。
注意:
成绩都为整数
标点符号为中文标点符号
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
namespace ConsoleApplication1
{
class Program
{
static void Main(string[] args)
{
float cj;
cj = Convert.ToSingle(Console.ReadLine());
if (cj >= 60)
{
Console.WriteLine("恭喜您,您通过了这次考试!");
}
else
{
Console.WriteLine("非常抱歉,您没有通过此次考试!");
}
}
}
}
查看全部 -
3.统计字符串中指定字符的数量
统计字符串中指定字符的数量
输入格式:
第一行输入给定字符串
第二行输入给定字符输出格式:
输出待统计字符个数
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
namespace ConsoleApp1
{
internal class Program
{
static void Main(string[] args)
{
string str;
str = Console.ReadLine();
int count = 0;
char y;
y = Convert.ToChar(Console.ReadLine());
for(int i = 0; i < str.Length; ++i)
{
if (str[i] == y)
{
++count;
}
}
Console.WriteLine(count);
}
}
}
查看全部 -
2.求解互补数
请编写程序求解输入数据的互补数,如果输入数据小于0则打印字符串输入数据不合法。互补数定义如下:
两个个位数(正整数)相加和为10的一对数,称为互补数
例如 : 1的互补数是9。
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
namespace ConsoleApplication1
{
class Program
{
static void Main(string[] args)
{
int a = Convert.ToInt32(Console.ReadLine());
if (a < 0)
{
Console.WriteLine("输入数据不合法");
}
else
{
Console.WriteLine("{0}", 10 - a);
}
}
}
}
查看全部 -
1.统计n到m之间能被s整除的数的总和
统计n到m之间(包括m)能被s整除的数的总和
输入格式:
第一行输入n,如1
第二行输入m,如100
第三行输入s,如3输出格式:
输出结果,如1683
using System;
class Program
{
static void Main()
{
int n = Convert.ToInt16(Console.ReadLine());
int m = Convert.ToInt16(Console.ReadLine());
int s = Convert.ToInt16(Console.ReadLine());
int sum = 0;
for(int i = n; i <= m; ++i)
{
if(i % s == 0)
{
sum += i;
}
}
Console.WriteLine(sum);
}
}
查看全部 -
for (int x = 1; x < 10; x++)
{
if (x==3||x==8)
continue;//请添加代码,过滤3和8
Console.Write(x);
查看全部 -
C#中的switch,每个分支都应该以break;结束,break的作用是跳出switch结构。但是,如果某个分支中没有语句,那么也可以不写break;
查看全部 -
switch 中的(变量)只能是3种类型:整型(如 int )、字符型( char )、字符串类型( string )。
查看全部 -
while循环
先判断循环条件,若条件为 true ,就执行循环体一次,然后再判断条件...当条件为 false 时,结束循环。
查看全部
举报